MojoliciousはPerl 5.10.1以上!

| | トラックバック(0)

MojoliciousをCPAN経由で入れようとしたらこけた。

Perl v5.10.1 required--this is only v5.10.0, stopped at Makefile.PL line 1.

ということで、Perlのバージョンが5.10.1以上じゃないとだめ。

使ってるMacのSystemのPerlバージョンは5.10.0なので、
あとちょっとのところでアウト。

plenvでもっと上のバージョンのPerl使えば何も問題ないわけだが、
いまだにApacheにplenvが指定しているPerlを使わせる方法がわからないので、 そっちに行けない・・・。

Apacheで動かしている、CGIプログラムはそのままにしてきたいので、 現状の自分のスキルだと身動きできない。

いっそ、Apacheやめて、違うWebサーバにして、 そっちでいま動かしているCGIプログラムを動かすようにすればよいのだろうか? うーん。

comments powered by Disqus

トラックバック(0)

このブログ記事を参照しているブログ一覧: MojoliciousはPerl 5.10.1以上!

このブログ記事に対するトラックバックURL: http://nozawashinichi.sakura.ne.jp/MT-4.25/mt-tb.cgi/1151

comments powered by Disqus

このブログ記事について

このページは、Shinichi Nozawaが2013年9月18日 21:54に書いたブログ記事です。

ひとつ前のブログ記事は「Apacheの環境変数のPATHを変えられなかった」です。

次のブログ記事は「さくらインターネットでPremature end of script headers: のエラー」です。

最近のコンテンツはインデックスページで見られます。過去に書かれたものはアーカイブのページで見られます。